1985 2.2 liter turbo Chrysler Idling problem

Go here for help using this forum.

Moderators: 89ARIES, Webmaster

1985 2.2 liter turbo Chrysler Idling problem

Postby rosemariedd » Wed Jun 29, 2016 4:15 am

At cold start up engine can hardly run at all - when up to temperature runs fine: any ideas as to what might be wrong????
rosemariedd
 
Posts: 4
Joined: Fri Sep 25, 2009 7:31 pm
Car Information: 85 Chrys.T&C Le Baron conv. Mrk Cross turbo

Re: 1985 2.2 liter turbo Chrysler Idling problem

Postby Kwagon2 » Thu Jun 30, 2016 12:54 pm

Hi
Hard to answer with just a little bit of info...is there some throttle response cold...as in once you get it started will the engine speed (rpm) increase with throttle movement? Have you checked for any fault codes? When was the last time the engine was tuned (check plugs, throttle body cleaning etc. ) Have you checked all vacuum lines for looseness or cracking ....far too many factors to just warrant a quick guess ...
Kwagon2
Car Fan
 
Posts: 133
Joined: Tue Jun 09, 2015 2:46 pm
Car Information: '82 Dodge Aries Wagon,'85 Plymouth Reliant SE

Re: 1985 2.2 liter turbo Chrysler Idling problem

Postby rosemariedd » Fri Jul 01, 2016 3:59 am

thanks car has only 45,000 miles in garage was running just fine and suddenly this happened little response to throttle once running
rosemariedd
 
Posts: 4
Joined: Fri Sep 25, 2009 7:31 pm
Car Information: 85 Chrys.T&C Le Baron conv. Mrk Cross turbo

Re: 1985 2.2 liter turbo Chrysler Idling problem

Postby K-CAR_WAGON » Fri Jul 01, 2016 5:11 pm

Did you check for fault codes? (See procedure in link - if you don't have a test device.)

http://minimopar.knizefamily.net/fault/
K-CAR_WAGON
Car Fan
 
Posts: 52
Joined: Tue Sep 29, 2009 5:42 pm
Car Information: Plymouth, Reliant Wagon, 1983


Return to Info and Forum Help

Who is online

Users browsing this forum: No registered users and 2 guests