Left flasher not working but the lights are all on

Post here for any Cars and Parts desired!

Moderator: 89ARIES

Left flasher not working but the lights are all on

Postby cmmwiebe » Sat Oct 16, 2010 3:02 pm

Just started driving my 84 E Class again and find that I do not have the left hand flashers. Right works fine and I can manually make the left side flash. Any Ideas?

Clayton
User avatar
cmmwiebe
 
Posts: 0
Joined: Sat Oct 16, 2010 3:49 am
Location: Saskatoon, SK Canada
Car Information: 1984 Chrysler E Class

Re: Left flasher not working but the lights are all on

Postby Silverbeard » Sat Oct 16, 2010 4:45 pm

Check all the bulbs again, had that problem once and with one bulb out it did not put enough load on the flasher unit to make it work properly.
Image Image
Silverbeard
Car Fan
 
Posts: 211
Joined: Sun Jun 01, 2008 11:51 pm
Location: Barrie, On. Canada
Car Information: 82 LeBaron Convertible, Mark Cross Edition, 2.6 L

Re: Left flasher not working but the lights are all on

Postby rare_ram » Sun Oct 17, 2010 2:45 am

I've found many 80s Mopars have a loose ground that causes issues. I put a small screw in to tighten them up.
rare_ram
Car Fan
 
Posts: 68
Joined: Mon Aug 31, 2009 11:27 am
Car Information: 1986 Dodge Lancer ES

Re: Left flasher not working but the lights are all on

Postby cmmwiebe » Sun Oct 17, 2010 3:30 pm

Thanks all. I will check this out. There are several issues with the power to lights and locks on the driver door so I want to pull the panel off and have a look. Maybe it is all connected.

Clayton
User avatar
cmmwiebe
 
Posts: 0
Joined: Sat Oct 16, 2010 3:49 am
Location: Saskatoon, SK Canada
Car Information: 1984 Chrysler E Class


Return to Club Wishlist

Who is online

Users browsing this forum: Google [Bot] and 2 guests