1989 Aries K LE surging while accelerating

Go here if you can't find the answers to your car's problems

Moderator: 89ARIES

1989 Aries K LE surging while accelerating

Postby Christina » Sat Aug 23, 2014 6:11 pm

Hi, all! My first fix-it type question here on the board!

Full disclosure: I know very little about cars and how they work, so please speak to me like a layman. (Laywoman?)

Yesterday I took my Aries to my mother's house about 30 minutes away from me. The highway I use to get there has a speed limit of 70, so I traveled around 75mph most of the way there with no issues. Then on another road where the speed limit is 55 with some stop lights, I noticed that the car was surging during acceleration when I was around the 50-55mph range. Once we got into town and the speeds were lower, around 35mph, the problem went away again. The oxygen sensor had been previously causing a similar problem for the previous owner, so it was replaced within the last 12 months. My dad is fairly car-savvy and when I described it to him, he said it sounded like a similar problem he's been having in his 1989 Ford van with his EGR valve. Something about when the car is traveling at higher velocities, the exhaust doesn't get recycled the same way as at lower velocities. Gonna be honest--it kinda went over my head, and I'm hoping someone here will know what he's referring to. Does this sound like it could be the problem? He doesn't have a code reader that will work on my car, so we weren't able to run any diagnostics, but he said that was his best guess. He also brought up a good point that I hadn't considered--I don't know when, if ever, the catalytic converter was last checked/replaced.

Any thoughts you guys have on this would be greatly appreciated! Thanks!
Christina
 

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron