I think my fuel pump may be failing.

As a K-car owner, you can encounter trouble with this motor. We'll help ya keep this reliable engine running.

Moderator: Webmaster

I think my fuel pump may be failing.

Postby 89ARIES » Mon Nov 14, 2011 6:01 pm

Good news: Check engine light is still acting normal. No new codes.
Challenge: Car is misbehaving so badly right now that its got to be easier now to figure out whats wrong. Something has totally
disrupted the delivery of gasoline. It now hesitates, bucks, attempts to stall in any weather and at any speed. I am getting a lot of resistance
in the gas petal. Also, sometimes if I depress the gas petal, it bogs and almost stalls, and then suddenly accelerates. Also, I am smelling
gasoline now at every start-up. Its almost like either gasoline is getting cut-off to the motor, or its being dumped. Gas mileage seems
to have gone down quickly in the last week alone. Also, on the freeway, I attempted to tempt fate by resting my foot on the gas petal, releasing
pressure from the petal, etc, and the car didn't quit, but it bucked and after bucking would suddenly lose power, but not totaly quit. I would
then have to "force" the gas to the engine. Some of these symptoms had always been present during the last two years, but now it suddenly just
got 100% pronounced in only a week and happening 24-7, with only a few breaks with the some relief from symptom frequency. Needless to say,
I am driving the car gently now and not attempting to floor it up to 85 with these problems. I am sure I may already be ruining my new oxygen sensor.
I did buy that LUCAS GAS TREATMENT over the weekend. Haven't put it in yet. Also, this is very important, the car starts up perfectly normal in cold weather and the idle
has not really changed, but has more stumbling at the same time I have more of the other symptoms. I hope a fuel pump will solve my problem.
User avatar
89ARIES
Chysler K Car Club Founder
 
Posts: 1841
Joined: Fri Aug 17, 2007 2:04 am
Location: Sylmar, California
Car Information: 1989 Dodge Aries

Re: I think my fuel pump may be failing.

Postby Jacks1986Lebaron » Mon Nov 14, 2011 9:28 pm

Wow....it "sounds" like it could be your fuel pump....mine only bogs slightly when ya let up on accelerator and then re-accelerate.

Bucking, bogging, losing power....sure sounds like it could be your fuel pump.

I had the fuel pump, fuel sock, and a new fuel filter installed in my 86 about 4000 miles ago. It cost $300 or theres about.
Jacks1986Lebaron
Car Fan
 
Posts: 460
Joined: Mon Jun 01, 2009 1:29 am
Location: Nashville
Car Information: Chrysler Lebaron 1986-2.5 automatic

Re: I think my fuel pump may be failing.

Postby 89ARIES » Mon Nov 14, 2011 9:37 pm

How difficult would it be for me to install it by myself?
User avatar
89ARIES
Chysler K Car Club Founder
 
Posts: 1841
Joined: Fri Aug 17, 2007 2:04 am
Location: Sylmar, California
Car Information: 1989 Dodge Aries

Re: I think my fuel pump may be failing.

Postby K-CAR_WAGON » Tue Nov 15, 2011 12:36 am

K-CAR_WAGON
Car Fan
 
Posts: 52
Joined: Tue Sep 29, 2009 5:42 pm
Car Information: Plymouth, Reliant Wagon, 1983

Re: I think my fuel pump may be failing.

Postby Butch » Fri Nov 18, 2011 5:39 am

If you're smelling gas you got a leak. Look for it, the fuel line at the tank is visible at the rear of the tank. Come by the shop.
Mopar or No car. Tires and Tits, Rock on.
Butch
Car Fan
 
Posts: 647
Joined: Sat Feb 28, 2009 6:59 am
Car Information: 86 Chrysler Laser BUILT 89 T2 2.5

Re: I think my fuel pump may be failing.

Postby shergood » Sun Aug 07, 2016 10:26 am

HELLO.....im new to the club and excited to hopefully find repair knowledge. :) I have an 88 Plymouth wagon w/ a 2.5 in it. The "symptoms" sounds just like the post above. Except I dont use mine til fixed. Starts right up, idles for 2 min then tries to die...I have to Tap tap the gas pedal to keep running ..I keep getting the CODE 25...AIS motor. Im wondering please if someone can post a labeled diagram for the throttle body? Theres 2 fuel lines then theres Sensors that plug in to it..I would appreciate so much if i knew what was all plugged into throttle body. Goal to find AIS motor and replace it.

thank you for taking the time to read...
Sher
shergood
 
Posts: 1
Joined: Sat Aug 06, 2016 8:51 pm


Return to Chrysler 2.2/2.2 T/2.5 Motor

Who is online

Users browsing this forum: No registered users and 1 guest

cron